Pangunahin Pc At Mac Sensitibo ba ang Mga Kaso ng Mga Email?

Sensitibo ba ang Mga Kaso ng Mga Email?



Mayroong maraming pagkalito kung ang mga email address ay case sensitive o hindi. Sinasabi ng ilan na sila ay, habang ang iba ay inaangkin na hindi sila. Kaya, sino ang tama? Sa artikulong ito, titingnan natin kung sensitibo sa kaso ang case ng email o hindi sensitibo sa kaso.

Sensitibo ba ang Mga Kaso ng Mga Email?

Ano ang Gumagawa ng isang Email Address?

Ang isang email address ay binubuo ng tatlong bahagi - ang lokal na bahagi (kilala rin bilang username), ang @ sign, at ang bahagi ng domain. Ang bawat bahagi ay may sariling papel at napapailalim sa sarili nitong hanay ng mga patakaran. Narito ang isang mabilis na pangkalahatang ideya.

Ayon sa pamantayan, ang lokal na bahagi ng email address ay maaaring hanggang sa 64 na character ang haba at maaaring mabuo ng isang limitadong hanay ng mga character. Kasama rito ang mga titik ng alpabeto ng alpabeto sa itaas at mas mababang kaso, mga numero mula 0 hanggang 9, tuldok, at mga espesyal na character. Kasama sa mga espesyal na character ang `[protektado ng email] # $% ^ & * () _- + = [] {} ~. Nakakonekta ito sa bahagi ng domain na may tanda na @.

Ang bahagi ng domain ay maaaring hanggang sa 255 character ang haba. Maaari itong maglaman ng mga titik ng alpabetong Latin (parehong mas mababa at itaas na kaso), mga numero mula 0 hanggang 9, at gitling. Hindi maaaring simulan o tapusin ng gitling ang bahagi ng domain.

Maaari ring magamit ang mga simbolong internasyonal, kahit na higit pa sa paglaon.

Sensitive ba ang Kaso?

Ang tamang sagot sa katanungang ito ay kapwa oo at hindi. Ayon kay RFC 5321 , ang lokal na bahagi ng email address ay sensitibo sa kaso. Nangangahulugan ito na, sa teorya, [ang protektado ng email] ay hindi pareho ng [protektado ng email] Gayunpaman, ang mga tagapagbigay ng email ay may kalayaan na gamutin ang mga lokal na bahagi bilang kapwa sensitibo sa kaso at hindi sensitibo sa kaso.

Halimbawa, [protektado ang email], [protektado ng email], at [protektado ng email] ay magkakaiba sa teoretikal na mga email address. Madaling makita kung paano ito maaaring lumikha ng mga problema at mabawasan ang karanasan ng gumagamit kung ang isang mail server ay nagpasyang tratuhin ang mga lokal na bahagi bilang case sensitive. Samakatuwid, itinuturing ng maraming mga tagabigay ang lokal na bahagi ng email address bilang case insensitive.

kung paano itakda ang default na gmail account

Tulad ng para sa bahagi ng domain, RFC 1035 Nakasaad na palaging hindi ito sensitibo. Nangangahulugan ito na maaari mo itong isulat sa mas mababang kaso, itaas na kaso, o anumang kombinasyon ng dalawa at ang iyong email ay magtatapos sa parehong address. Sa praktikal na paggamit, ang [email protektado], [email protektado], at [email protektado] ay pareho ng email address.

Sa Pagsasanay

Habang ang mga email address ay bahagyang sensitibo lamang sa kaso, sa pangkalahatan ay ligtas na isipin ang mga ito bilang case insensitive. Lahat ng mga pangunahing tagabigay, tulad ng Gmail, Yahoo Mail, Hotmail, at iba pa, ay tinatrato ang mga lokal na bahagi ng mga email address na case insensitive. Sinabi na, dapat mong suriin ang mga patakaran ng provider ng email kung saan mo nais lumikha ng isang email.

Nakakatali sa nakaraang punto, inirerekomenda ng nabanggit sa itaas na RFC 5321 para sa mga bagong email address na nilikha na may mga titik na mas maliit ang kaso lamang upang maiwasan ang mga potensyal na pagkalito at mga problema sa paghahatid.

Sa kabilang banda, kung ang iyong kaibigan o kasamahan ay mayroong isang email address na may kumbinasyon ng mga character na pang-itaas at maliit na kaso, ipinapayong isulat ito tulad ng kapag nagpapadala ka sa kanila ng isang email. Ang kabiguang gawin ito ay maaaring maging sanhi ng hindi maihatid ang email. Gayunpaman, hindi ito isang isyu sa mga pangunahing tagapagbigay ng email tulad ng Gmail, Yahoo Mail, Hotmail, at iba pa.

Bilang karagdagan, ang Gmail ay hindi rin sensitibo sa mga tuldok na matatagpuan sa lokal na bahagi ng email pagdating sa pagkakakilanlan ng account ng gumagamit. Nangangahulugan ito na kung mayroon ang [protektado ng email] na account, hindi ka makakapagrehistro [protektado ng email] o [protektado ng email]

Internalisasyon

Orihinal, ang mga email address ay maaaring nakarehistro lamang gamit ang mga titik ng alpabetong Latin, mga numero, at isang limitadong hanay ng mga espesyal na character na ASCII. Gayunpaman, ang IETF (Internet Engineering Task Force) ay kasunod na bumuo ng mga patakaran at pamantayan para sa pagsasama ng mga internasyonal na character.

RFC6530 ang unang nagsama at kinokontrol ang paggamit ng mga international character. RFC6531 pinalawak sa mga patakaran at pamantayan. Kasunod, ang mga patakaran at pamantayan ay na-update sa pamamagitan ng RFC6532 at RFC6533 .

Maaari ka na ngayong magparehistro ng isang email address gamit ang isang malawak na hanay ng mga alpabeto, character, at script. Ang ilan sa mga pinakalawak na ginamit ay nagsasama ng mga Latin character na may diacritics, Greek alpabeto, Tradisyonal na Chinese character, Japanese character (hiragana, katakana, at kanji), alpabetong Cyrillic, maraming mga script ng India, pati na rin ang hanay ng iba pa.

Ang pagsasama ng at pagiging tugma sa mga pang-internasyonal na email address ay nag-iiba mula sa provider hanggang sa provider. Kahit na ang ilan sa mga pinakamalaking tagabigay ay hindi ganap na tugma sa mga pang-internasyonal na address. Halimbawa, pinapayagan ka ng Google na magpadala ng isang email sa isang pang-internasyonal na address ngunit hindi ka nito pinapayagan na lumikha ng isa. Ang Outlook 2016 ay may katulad na pag-andar.

Konklusyon

Hindi tulad ng bahagi ng domain name, sensitibo sa case ang lokal na bahagi ng isang email address. Sinabi na, maraming mga provider ng email ang pumili na huwag pansinin ang pagkasensitibo ng kaso ng lokal na bahagi para sa mga praktikal na kadahilanan at hikayatin ang mga tao na lumikha ng mga email na may mga character na mas maliit lamang ang kaso.

Kagiliw-Giliw Na Mga Artikulo

Choice Editor

Paano Masasabi kung May Isang Tanggalin ang Iyong Pakikipag-usap sa Snapchat
Paano Masasabi kung May Isang Tanggalin ang Iyong Pakikipag-usap sa Snapchat
Ang Snapchat ay isang tanyag na application ng social media na gumawa ng paraan sa tuktok dahil sa kultura ng privacy ng gumagamit. Nagpapadala ng mga snap at mensahe na hindi nag-iiwan ng bakas, awtomatikong tinatanggal ang nilalaman, at binabalaan ang mga gumagamit kung nakunan ang isang screenshot,
Paano Masasabi kung May Nagta-type sa Snapchat
Paano Masasabi kung May Nagta-type sa Snapchat
Naaalala ang mga araw kung kailan ka magpapadala ng isang mensahe nang hindi mo nalalaman kung naihatid na ito o kung nabasa ito ng tatanggap o hindi? Nakasalalay sa iyong edad, ang sagot ay maaaring talagang 'hindi,' tulad ng halos bawat matalino
Patayin ang Hard Disk Pagkatapos ng Idle sa Windows 10
Patayin ang Hard Disk Pagkatapos ng Idle sa Windows 10
Makikita natin kung paano i-off ang hard disk pagkatapos na idle sa Windows 10. Ang isang espesyal na pagpipilian sa Windows 10 ay nagbibigay-daan sa gumagamit na awtomatikong i-off ang mga hard drive.
iPhone X – Paano Baguhin ang Wallpaper
iPhone X – Paano Baguhin ang Wallpaper
Ginagamit mo pa rin ba ang stock na wallpaper sa iyong iPhone X? Bakit may boring na telepono kung napakaraming paraan para i-customize ang screen ayon sa iyong panlasa? Binibigyang-daan ka ng iPhone X na itakda ang iyong paboritong larawan bilang
Paano Magtanggal para sa Pareho sa WhatsApp
Paano Magtanggal para sa Pareho sa WhatsApp
Kung gumagamit ka ng WhatsApp para sa negosyo o pakikisalamuha, maaaring gusto mong tanggalin ang mga mensahe. Marahil ay nagpadala ka ng mensahe na may mga typo nang hindi sinasadya, o nag-attach ng mga maling larawan o attachment. Bilang kahalili, maaari kang nagpadala ng mensahe sa mali
Paano Mag-trim ng isang Video
Paano Mag-trim ng isang Video
Mayroong maraming mga paraan upang i-trim ang isang video, pipiliin mo man itong gawin gamit ang iyong device o isang program. Hindi lamang ang mga opsyon ay walang katapusan, ngunit ito ay isang medyo tapat na proseso din. Alam kung paano
Paano Palitan ang iyong Pangalan sa Clash of Clans
Paano Palitan ang iyong Pangalan sa Clash of Clans
Ang iyong pangalan ng Clash of Clans ay isa sa pinakamahalagang salik na nagpapakilala. Hinahayaan ka nitong tumayo mula sa iyong mga kaaway at maaari pa ngang maglagay ng ngiti sa mga mukha ng ilang manlalaro. Habang pinalawak mo ang iyong imperyo, maaaring gusto mo